aboutsummaryrefslogtreecommitdiff
path: root/3rd-party/SingleApplication/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-07-02 09:24:39 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-07-02 09:24:39 +0200
commit9fbab94798455c79bfadee9041a78bd47ff642e4 (patch)
tree48aeaec9ad406caab07f7f4449cf01eebb17ea9c /3rd-party/SingleApplication/CMakeLists.txt
parentAdd WIN32 to windows executable (diff)
downloadsmolbote-9fbab94798455c79bfadee9041a78bd47ff642e4.tar.xz
Replace SingleApplication with itay-grudev/SingleApplication
Diffstat (limited to '3rd-party/SingleApplication/CMakeLists.txt')
-rw-r--r--3rd-party/SingleApplication/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/3rd-party/SingleApplication/CMakeLists.txt b/3rd-party/SingleApplication/CMakeLists.txt
new file mode 100644
index 0000000..5de0253
--- /dev/null
+++ b/3rd-party/SingleApplication/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Find includes in corresponding build directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+# Instruct CMake to run moc automatically when needed.
+set(CMAKE_AUTOMOC ON)
+#set(CMAKE_AUTOUIC ON)
+#set(CMAKE_AUTORCC ON)
+
+add_library(SingleApplication
+ singleapplication.cpp
+ singleapplication.h
+ singleapplication_p.h)
+
+target_link_libraries(SingleApplication
+ Qt5::Core Qt5::Network Qt5::Widgets
+)
+
+target_compile_definitions(SingleApplication
+ PRIVATE QAPPLICATION_CLASS=QApplication
+)
+
+if(${CMAKE_SYSTEM_NAME} MATCHES "Windows")
+ target_link_libraries(SingleApplication
+ Advapi32
+ )
+endif()