aboutsummaryrefslogtreecommitdiff
path: root/3rd-party/breakpad/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-09-26 18:10:28 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-09-26 18:10:28 +0200
commit40e7ca4c71a5777ead1699a7264cb39606504596 (patch)
treef585dfd45d8e2177ec1d12b746d6e845375002df /3rd-party/breakpad/CMakeLists.txt
parentBookmarks: remove debug defines (diff)
downloadsmolbote-40e7ca4c71a5777ead1699a7264cb39606504596.tar.xz
Add breakpad submodule
Diffstat (limited to '3rd-party/breakpad/CMakeLists.txt')
-rw-r--r--3rd-party/breakpad/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/3rd-party/breakpad/CMakeLists.txt b/3rd-party/breakpad/CMakeLists.txt
new file mode 100644
index 0000000..dd0ef8e
--- /dev/null
+++ b/3rd-party/breakpad/CMakeLists.txt
@@ -0,0 +1,11 @@
+if(${CMAKE_SYSTEM_NAME} MATCHES "Linux")
+
+ if (NOT EXISTS "${CMAKE_CURRENT_LIST_DIR}/install")
+ message(FATAL_ERROR "Could not find breakpad build, see 3rd-party/breakpad/build.sh")
+ endif ()
+
+ find_package(PkgConfig REQUIRED)
+ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${CMAKE_CURRENT_LIST_DIR}/install/lib/pkgconfig" )
+ pkg_check_modules(BREAKPAD REQUIRED IMPORTED_TARGET breakpad-client)
+
+endif() # linux system \ No newline at end of file