aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-09-26 18:10:28 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-09-26 18:10:28 +0200
commit40e7ca4c71a5777ead1699a7264cb39606504596 (patch)
treef585dfd45d8e2177ec1d12b746d6e845375002df /CMakeLists.txt
parentBookmarks: remove debug defines (diff)
downloadsmolbote-40e7ca4c71a5777ead1699a7264cb39606504596.tar.xz
Add breakpad submodule
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a966253..90aa0ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required(VERSION 3.10.0)
-project(smolbote CXX)
+project(smolbote)
include(FeatureSummary)
@@ -11,6 +11,7 @@ option(QtDeprecatedWarnings "Qt deprecated warnings" ON)
option(UseLibCpp "Use libc++ over stdlibc++ (requires clang)" OFF)
option(Tests "Enable/disable some basic autotests" OFF)
option(Plasma "Enable some fancy effects on Plasma" OFF)
+option(Breakpad "Enable breakpad crash reports" OFF)
# Libraries
find_package(Qt5 COMPONENTS Core Widgets Concurrent REQUIRED)
@@ -40,6 +41,9 @@ endif (UseLibCpp)
configure_file("${PROJECT_SOURCE_DIR}/src/version.h.in" "${PROJECT_BINARY_DIR}/src/version.h")
add_subdirectory(3rd-party/SingleApplication)
+if(Breakpad)
+ add_subdirectory(3rd-party/breakpad)
+endif()
add_subdirectory(lib/about)
add_subdirectory(lib/addressbar)