aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-01-19 02:10:31 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-01-19 02:10:31 +0100
commit49ee5ed6e80b8f06337f92d14e2cab1c1512c1e3 (patch)
treee35d5472c2a3ed129f5a6a6826f9999b033cc548 /CMakeLists.txt
parentConfiguration creates missing items based on defaults (diff)
downloadsmolbote-49ee5ed6e80b8f06337f92d14e2cab1c1512c1e3.tar.xz
Refactoring MainWindow
- Added NavigationBar object that manages the navigation buttons - Removed NavigationButton class that it obsoleted
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 589ccfb..bb0c2ca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,11 +66,11 @@ set(SourceCode
# main window
# todo: move all to src/mainwindow
- "src/mainwindow.cpp"
- "src/mainwindow.h"
- "src/mainwindow.ui"
- "src/widgets/loadingbar.cpp"
- "src/widgets/loadingbar.h"
+ src/mainwindow/mainwindow.cpp
+ src/mainwindow/mainwindow.h
+ src/mainwindow/mainwindow.ui
+ src/mainwindow/widgets/loadingbar.cpp
+ src/mainwindow/widgets/loadingbar.h
"src/widgets/mainwindowmenubar.cpp"
"src/widgets/mainwindowmenubar.h"
"src/widgets/mainwindowtabbar.cpp"
@@ -104,7 +104,7 @@ set(SourceCode
# plugin interfaces
plugins/interfaces.h
- )
+ src/mainwindow/widgets/navigationbar.cpp src/mainwindow/widgets/navigationbar.h)
add_executable(poi ${SourceCode})