aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-03-23 17:07:49 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-03-23 17:07:49 +0100
commit55f5a827a7abc2f248c2405e1977222062b88e6b (patch)
tree9c49e8fa9b96072ee8c8e4b7ff0e82cd322be1f0 /CMakeLists.txt
parentpoi-config saving config (diff)
downloadsmolbote-55f5a827a7abc2f248c2405e1977222062b88e6b.tar.xz
Cookie filter
- Requires Qt 5.11 (now required) - New settings: filter.cookies: block.all, block.thirdParty, path
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a7cd876..88d461c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,10 +7,7 @@ option(QtDeprecatedWarnings "Qt deprecated warnings" ON)
option(UseLibCpp "Use libc++ over stdlibc++ (requires clang)" OFF)
# Libraries
-find_package(Qt5Core REQUIRED)
-find_package(Qt5Widgets REQUIRED)
-find_package(Qt5Concurrent REQUIRED)
-find_package(Qt5WebEngineWidgets REQUIRED)
+find_package(Qt5 5.11 COMPONENTS Core Widgets Concurrent WebEngineWidgets REQUIRED)
find_package(Boost COMPONENTS program_options REQUIRED)
# Global C++ settings