aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-07-29 14:08:27 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-07-29 14:08:27 +0200
commit9c47ceeef79caa02c5ee810659d8f784676b3f71 (patch)
tree97282bbdc20b844cd7ca63cdb82af67ba1dc5098 /CMakeLists.txt
parentUrlRequestInterceptor: add filter rules (diff)
downloadsmolbote-9c47ceeef79caa02c5ee810659d8f784676b3f71.tar.xz
Update build instructions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba57c85..a09a589 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,7 +15,7 @@ option(Plasma "Enable some fancy effects on Plasma" OFF)
# Libraries
find_package(Qt5 COMPONENTS Core Widgets Concurrent REQUIRED)
find_package(Qt5 5.11.0 COMPONENTS WebEngineWidgets REQUIRED)
-find_package(Boost COMPONENTS program_options REQUIRED)
+find_package(Boost 1.66 COMPONENTS program_options REQUIRED)
if(Plasma)
find_package(ECM 1.6.0 REQUIRED NO_MODULE)
@@ -37,8 +37,6 @@ if (UseLibCpp)
endif (UseLibCpp)
# configure a header file to pass version information
-# if repo is missing or option is turned off, version.h.in can be configured
-# with static values
configure_file("${PROJECT_SOURCE_DIR}/src/version.h.in" "${PROJECT_BINARY_DIR}/src/version.h")
add_subdirectory(3rd-party/SingleApplication)