aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-06-16 09:46:48 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-06-16 09:46:48 +0200
commitb936bccd9d0d7f50f37c078b7aad9e75ee9fc981 (patch)
tree8387c8cbce8c4924a71fa34d7df124f8593a0e94 /CMakeLists.txt
parentBookmarks manager bugfixes (diff)
downloadsmolbote-b936bccd9d0d7f50f37c078b7aad9e75ee9fc981.tar.xz
Add Plasma option to cmake that turns on KF5 blur window effect
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cb86ce6..a4f64d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,12 +9,19 @@ option(CompilerWarnings "Compiler warnings" ON)
option(QtDeprecatedWarnings "Qt deprecated warnings" ON)
option(UseLibCpp "Use libc++ over stdlibc++ (requires clang)" OFF)
option(Tests "Enable/disable some basic autotests" ON)
+option(Plasma "Enable some fancy effects on Plasma" OFF)
# Libraries
find_package(Qt5 COMPONENTS Core Widgets Concurrent REQUIRED)
find_package(Qt5 5.10.1 COMPONENTS WebEngineWidgets REQUIRED)
find_package(Boost COMPONENTS program_options REQUIRED)
+if(Plasma)
+ find_package(ECM 1.6.0 REQUIRED NO_MODULE)
+ set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
+ find_package(KF5 "5.6.0" COMPONENTS WindowSystem REQUIRED)
+endif(Plasma)
+
# Global C++ settings
set(CMAKE_CXX_STANDARD 17)