aboutsummaryrefslogtreecommitdiff
path: root/config/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-06-23 12:50:10 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-06-23 12:50:10 +0200
commit41329fae5f819eee8c394571125f11f0a0b67cd9 (patch)
treee8e36f9b8458ee809114714e497c4a43a19949ef /config/CMakeLists.txt
parentAdd Configuration::setValue and Configuration::setShortcut (diff)
downloadsmolbote-41329fae5f819eee8c394571125f11f0a0b67cd9.tar.xz
Add ConfigurationEditor plugin
Removed poi-config
Diffstat (limited to 'config/CMakeLists.txt')
-rw-r--r--config/CMakeLists.txt26
1 files changed, 0 insertions, 26 deletions
diff --git a/config/CMakeLists.txt b/config/CMakeLists.txt
deleted file mode 100644
index 7ee13b0..0000000
--- a/config/CMakeLists.txt
+++ /dev/null
@@ -1,26 +0,0 @@
-# Find includes in corresponding build directories
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-# Instruct CMake to run moc automatically when needed.
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTOUIC ON)
-set(CMAKE_AUTORCC ON)
-
-add_executable(poi-config
- main.cpp
- settingsdialog.cpp
- settingsdialog.h
-)
-
-target_include_directories(poi-config
- PRIVATE ../lib/configuration
- PRIVATE ${Boost_INCLUDE_DIRS}
-)
-
-target_link_libraries(poi-config
- Qt5::Core Qt5::Widgets
- ${Boost_LIBRARIES}
- configuration
-)
-
-install(TARGETS poi-config RUNTIME DESTINATION bin CONFIGURATIONS Release)