aboutsummaryrefslogtreecommitdiff
path: root/doc/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-12-30 14:31:36 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-12-30 15:07:03 +0100
commit34bf7efcd2ece2b0d5f96183da4e79d4258fe559 (patch)
tree6fef25416d4f850e1f493db2ed21f7dea857eac4 /doc/meson.build
parentBookmarks: track modified state in the model rather than the widget (diff)
downloadsmolbote-34bf7efcd2ece2b0d5f96183da4e79d4258fe559.tar.xz
Add smolbote.5 manpage
Configuration file and Options description manpage
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/doc/meson.build b/doc/meson.build
index 6e51e39..d45aea1 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -11,4 +11,18 @@ if get_option('manpage').enabled()
install: true, install_dir: join_paths(get_option('mandir'), 'man7')
)
+ custom_target('manpage.5',
+ # list of files this target depends on
+ depend_files: ['smolbote.5.asciidoc'],
+
+ input: 'smolbote.5.asciidoc',
+ output: 'smolbote.5',
+
+ command: [asciidoctor, '--backend=manpage', '--out-file=@OUTPUT@', '@INPUT@'],
+
+ build_by_default: true,
+ install: true,
+ install_dir: get_option('mandir') / 'man5'
+ )
+
endif