aboutsummaryrefslogtreecommitdiff
path: root/include/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-02-15 14:53:56 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2020-02-29 15:41:55 +0200
commit26e2926d5424f0c248892b4755c699541d46e856 (patch)
tree16ed0e75a31c4779d4d140b07262e89bca6971a0 /include/meson.build
parentAdded example firefox/palemoon bookmarks to test (diff)
downloadsmolbote-26e2926d5424f0c248892b4755c699541d46e856.tar.xz
Remove ProfileInterface
Plugins should define their own specific interfaces rather than subclassing from ProfileInterface: - add Filter for QWebEngineUrlRequestInterceptor filters - add FilterPlugin for Filter loading Remove deprecated Browser::profileList()
Diffstat (limited to 'include/meson.build')
-rw-r--r--include/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/include/meson.build b/include/meson.build
new file mode 100644
index 0000000..c2bf758
--- /dev/null
+++ b/include/meson.build
@@ -0,0 +1,6 @@
+dep_plugininterface = declare_dependency(
+ include_directories: include_directories('.')
+)
+
+plugininterface_include = include_directories('.')
+