aboutsummaryrefslogtreecommitdiff
path: root/lang/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-12-07 12:22:15 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2020-12-07 12:22:15 +0200
commit92b3c2dcff3e85ad3d455f6ab845d9a97d3b525b (patch)
treea850643f7b86e6cebfddbeec98d7c372478d379c /lang/CMakeLists.txt
parentHostlist filter plugin can rewrite hostnames (diff)
downloadsmolbote-92b3c2dcff3e85ad3d455f6ab845d9a97d3b525b.tar.xz
Rewrite meson build scripts into cmakelists
Diffstat (limited to 'lang/CMakeLists.txt')
-rw-r--r--lang/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/lang/CMakeLists.txt b/lang/CMakeLists.txt
new file mode 100644
index 0000000..319c706
--- /dev/null
+++ b/lang/CMakeLists.txt
@@ -0,0 +1,10 @@
+# https://wiki.qt.io/How_to_create_a_multi_language_application
+
+# generating .ts files
+# lupdate -verbose src/ -ts output.ts
+
+# updating .ts files
+# lupdate -verbose -no-obsolete src/ -ts output.ts
+
+# creating the binary language files (.qm)
+# lrelease -compress -removeidentical input.ts [-qm output.qm]