aboutsummaryrefslogtreecommitdiff
path: root/lib/about/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2019-10-13 18:25:49 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2019-10-13 18:25:49 +0300
commit22e4c0b2bfea51c9f48d0d84e527ffe4c8eb0e25 (patch)
tree296b8e0be37ffd3f46f1d66dcf7d3ffc6f0b6a8a /lib/about/meson.build
parentAdd some cpp compiler options and warnings (diff)
downloadsmolbote-22e4c0b2bfea51c9f48d0d84e527ffe4c8eb0e25.tar.xz
Improve meson.build files
- meson should now properly create OpenSSL signing key and hexdump before trying to compile plugin loader
Diffstat (limited to 'lib/about/meson.build')
-rw-r--r--lib/about/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/about/meson.build b/lib/about/meson.build
index e6228c4..531355d 100644
--- a/lib/about/meson.build
+++ b/lib/about/meson.build
@@ -7,6 +7,6 @@ about_moc = mod_qt5.preprocess(
dep_about = declare_dependency(
include_directories: include_directories('.'),
link_with: static_library('about',
- ['aboutdialog.cpp', 'aboutplugin.cpp', about_moc],
- dependencies: [dep_qt5, dep_genheaders])
+ ['aboutdialog.cpp', 'aboutplugin.cpp', about_moc, version_h],
+ dependencies: [dep_qt5])
)