aboutsummaryrefslogtreecommitdiff
path: root/lib/bookmarks/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-09-24 14:55:35 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-09-24 14:55:35 +0200
commit579c713959c150a276f42b3f69ccfb89d9e6eebb (patch)
tree7c4f2082e2ff5dcdee7fcfe7887e7bbc82ec8bf6 /lib/bookmarks/CMakeLists.txt
parentAdd bookmark auto-save (5min) (diff)
downloadsmolbote-579c713959c150a276f42b3f69ccfb89d9e6eebb.tar.xz
Bookmarks: add BookmarkItem and BookmarkModel
- read-only xbel - only enabled in debug build
Diffstat (limited to 'lib/bookmarks/CMakeLists.txt')
-rw-r--r--lib/bookmarks/CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/lib/bookmarks/CMakeLists.txt b/lib/bookmarks/CMakeLists.txt
index b7bbf0d..d2256c6 100644
--- a/lib/bookmarks/CMakeLists.txt
+++ b/lib/bookmarks/CMakeLists.txt
@@ -14,8 +14,16 @@ add_library(bookmarks
bookmarksview.h
# xbel
xbel.cpp
- xbel.h)
+ xbel.h
-target_include_directories(bookmarks
- PRIVATE ${CMAKE_CURRENT_SOURCE_DIR})
-target_link_libraries(bookmarks Qt5::Widgets) \ No newline at end of file
+ # bookmark item/model/view
+ bookmarkitem.cpp
+ bookmarkitem.h
+ bookmarkmodel.cpp
+ bookmarkmodel.h
+ forms/editbookmarkdialog.cpp
+ forms/editbookmarkdialog.h
+ forms/editbookmarkdialog.ui
+)
+
+target_link_libraries(bookmarks Qt5::Widgets)