aboutsummaryrefslogtreecommitdiff
path: root/lib/bookmarks/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-02-07 21:08:39 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-02-07 21:08:39 +0100
commitf779510603e01de438e337c82c439cc6649cd7c3 (patch)
tree98254e5ab079edcc6e207d692af28378573d4f0f /lib/bookmarks/CMakeLists.txt
parentBookmarks bugfixes (diff)
downloadsmolbote-f779510603e01de438e337c82c439cc6649cd7c3.tar.xz
Rewrote bookmark manager to use QTreeWidget over QTreeView
- cut out all the boilerplate that was BookmarkItem/BookmarksModel - deleting items no longer crash; proper drag'n'drop - Split Xbel into XbelReader and XbelWriter
Diffstat (limited to 'lib/bookmarks/CMakeLists.txt')
-rw-r--r--lib/bookmarks/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/lib/bookmarks/CMakeLists.txt b/lib/bookmarks/CMakeLists.txt
index 53ba51e..e94c494 100644
--- a/lib/bookmarks/CMakeLists.txt
+++ b/lib/bookmarks/CMakeLists.txt
@@ -4,13 +4,12 @@ add_library(bookmarks
bookmarksform.ui
bookmarkswidget.cpp
bookmarkswidget.h
- # model
- bookmarkitem.cpp
- bookmarkitem.h
- bookmarksmodel.cpp
- bookmarksmodel.h
+ bookmarksview.cpp
+ bookmarksview.h
# xbel
xbel.cpp
xbel.h)
+target_include_directories(bookmarks
+ PRIVATE ${CMAKE_CURRENT_SOURCE_DIR})
target_link_libraries(bookmarks Qt5::Widgets) \ No newline at end of file