aboutsummaryrefslogtreecommitdiff
path: root/lib/session_formats/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-04-13 15:44:09 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-04-13 15:44:09 +0300
commit396bc0c1721af8d3ee970228e7df457f6b2c73d5 (patch)
tree5aee4f0faec3fdfe616e1684dcb1736be9126bc1 /lib/session_formats/meson.build
parentAdd singleapplication.wrap (diff)
downloadsmolbote-396bc0c1721af8d3ee970228e7df457f6b2c73d5.tar.xz
Rewrite Session backend
Add session.hpp, containing structs that describe session data MainWindow, SubWindow and WebView can be created from Session::structs Opening new window will automatically open a default subwindow and tab if none were specified Add lib/session_formats Add JsonSession, to serialize/deserialize Session structs into JSON - add some tests clang-tidy: - fix various warnings - disable modernize-use-trailing-return-type check
Diffstat (limited to 'lib/session_formats/meson.build')
-rw-r--r--lib/session_formats/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/lib/session_formats/meson.build b/lib/session_formats/meson.build
new file mode 100644
index 0000000..9abf5a2
--- /dev/null
+++ b/lib/session_formats/meson.build
@@ -0,0 +1,13 @@
+lib_session_formats = declare_dependency(
+ include_directories: [ '.', include ],
+ link_with: library('sessionformats',
+ [ 'session_json.cpp' ],
+ include_directories: include,
+ dependencies: dep_qt5
+ )
+)
+
+test('session: json format', executable('session_json',
+ sources: 'test/json.cpp',
+ dependencies: [ dep_qt5, dep_catch, lib_session_formats ]
+))