aboutsummaryrefslogtreecommitdiff
path: root/lib/web/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-06-07 13:03:47 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-06-07 13:03:47 +0200
commit7707fb4ed8ad8c951d9f41ce39823093d30a9f67 (patch)
treea70e08ba2d03afb68109ea89f370f8873e3645f5 /lib/web/CMakeLists.txt
parentDon't copy profiles into profile manager plugin (diff)
downloadsmolbote-7707fb4ed8ad8c951d9f41ce39823093d30a9f67.tar.xz
Split webengine/webprofile into lib/web
Diffstat (limited to 'lib/web/CMakeLists.txt')
-rw-r--r--lib/web/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/web/CMakeLists.txt b/lib/web/CMakeLists.txt
new file mode 100644
index 0000000..c5d5eba
--- /dev/null
+++ b/lib/web/CMakeLists.txt
@@ -0,0 +1,17 @@
+# Find includes in corresponding build directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+# Instruct CMake to run moc automatically when needed.
+set(CMAKE_AUTOMOC ON)
+
+add_library(web
+ webprofile.cpp
+ webprofile.h
+)
+
+#target_include_directories(web
+# PRIVATE ${Boost_INCLUDE_DIRS}
+# PRIVATE ..
+#)
+
+target_link_libraries(web Qt5::WebEngineWidgets)