aboutsummaryrefslogtreecommitdiff
path: root/lib/webengine/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-12-15 23:09:06 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2020-12-15 23:09:06 +0200
commitafcfe0ca21e0102591378af1a3eac71937bd271c (patch)
treecdd18c174b08260db9ec04ca565a3bb05ef270ce /lib/webengine/CMakeLists.txt
parentMove src/webengine to lib/webengine (diff)
downloadsmolbote-afcfe0ca21e0102591378af1a3eac71937bd271c.tar.xz
webengine: remove dependency on autogen/utilsdevel
Diffstat (limited to 'lib/webengine/CMakeLists.txt')
-rw-r--r--lib/webengine/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/lib/webengine/CMakeLists.txt b/lib/webengine/CMakeLists.txt
index ba3017f..3e5fa71 100644
--- a/lib/webengine/CMakeLists.txt
+++ b/lib/webengine/CMakeLists.txt
@@ -4,8 +4,7 @@ add_library(webengine STATIC
webview.h webview.cpp webviewcontextmenu.h webviewcontextmenu.cpp
urlinterceptor.h urlinterceptor.cpp)
target_include_directories(webengine PUBLIC ${CMAKE_SOURCE_DIR}/include ${CMAKE_CURRENT_SOURCE_DIR})
-# autogen: required for context menu icons; TODO: move context menu to src/
-target_link_libraries(webengine PUBLIC Qt5::WebEngineWidgets autogen fmt)
+target_link_libraries(webengine PUBLIC Qt5::WebEngineWidgets fmt)
# tests
add_executable(profile_test test/profile.cpp)