aboutsummaryrefslogtreecommitdiff
path: root/lib/webprofile/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2019-01-16 16:52:07 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2019-01-16 16:52:07 +0100
commit2a696a57abafb25978aef1af5758fe75b706d1f0 (patch)
tree9c9b3468398b16711a573e0c8b87ae2ad03100b4 /lib/webprofile/meson.build
parentRewrite lib/urlfilter (diff)
downloadsmolbote-2a696a57abafb25978aef1af5758fe75b706d1f0.tar.xz
Rewrite lib/web to lib/webprofile
- libweb was supposed to be a general QtWebEngine wrapper, but only turned out to do profiles and profile management. The new name should make this more obvious. - Renamed ProfileManager to WebProfileManager, and cut out duplicate code. - Temporary profiles: temporary profiles are not kept after closing the browser.
Diffstat (limited to 'lib/webprofile/meson.build')
-rw-r--r--lib/webprofile/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/lib/webprofile/meson.build b/lib/webprofile/meson.build
new file mode 100644
index 0000000..af4cfcb
--- /dev/null
+++ b/lib/webprofile/meson.build
@@ -0,0 +1,12 @@
+webprofile_lib = static_library('webprofile',
+ ['webprofilemanager.cpp', 'webprofile.cpp', interfaces_moc,
+ qt5.preprocess(moc_headers: ['webprofilemanager.h', 'webprofile.h'], dependencies: dep_qt5)],
+ dependencies: dep_qt5,
+ include_directories: [include]
+)
+
+dep_webprofile = declare_dependency(
+ include_directories: include_directories('.'),
+ link_with: webprofile_lib
+)
+