aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD.aqua
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-01-16 15:41:45 +0100
committerAqua-sama <aqua@iserlohn-fortress.net>2018-01-16 15:41:45 +0100
commitc3b20dc648cfd02d3a26bbd6fab0db5a7d39fc05 (patch)
tree573ad55f55da490d02d500875de8c53848702f59 /linux/makepkg/PKGBUILD.aqua
parentConverted repository to mercurial (diff)
downloadsmolbote-c3b20dc648cfd02d3a26bbd6fab0db5a7d39fc05.tar.xz
Fixed build scripts for use with the mercurial repository
Diffstat (limited to 'linux/makepkg/PKGBUILD.aqua')
-rw-r--r--linux/makepkg/PKGBUILD.aqua58
1 files changed, 0 insertions, 58 deletions
diff --git a/linux/makepkg/PKGBUILD.aqua b/linux/makepkg/PKGBUILD.aqua
deleted file mode 100644
index 72b8536..0000000
--- a/linux/makepkg/PKGBUILD.aqua
+++ /dev/null
@@ -1,58 +0,0 @@
-# Maintainer: Aqua-sama <aqua@iserlohn-fortress.net>
-
-pkgname=smolbote-git
-pkgver=0.0.0
-pkgrel=1
-pkgdesc='Yet another no-frills browser'
-url="https://neueland.iserlohn-fortress.net/smolbote"
-
-arch=('x86_64')
-license=('GPL3')
-
-depends=('qt5-webengine' 'libconfig')
-makedepends=('git' 'cmake' 'pkg-config' 'ninja' 'qt5-webengine' 'libconfig')
-
-source=("smolbote-git::git+git://neueland.iserlohn-fortress.net/smolbote.git")
-sha512sums=('SKIP')
-
-# any patches go here
-#prepare() {
-#}
-
-pkgver() {
- cd smolbote-git
- echo "$(git describe --long --tags | tr - .)"
-}
-
-build() {
- rm -rf "$pkgname-$pkgver"
- mkdir "$pkgname-$pkgver"
- cd "$pkgname-$pkgver"
-
- # CMake Options
- # build type
- _cmake_options="-DCMAKE_BUILD_TYPE=Release"
-
- # install prefix, or where should the binary be installed
- _cmake_options="$_cmake_options -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/local"
-
- # compiler
- _cmake_options="$_cmake_options -DCMAKE_CXX_COMPILER=/usr/bin/clang++"
-
- # use libc++ instead of libstdc++
- #_cmake_options="$_cmake_options -DUseLibCpp=On"
-
- # build system
- _cmake_options="$_cmake_options -GNinja"
-
- # Generate a makefile
- cmake $_cmake_options "$srcdir/smolbote-git"
-
- # build
- ninja
-}
-
-package() {
- cd "$pkgname-$pkgver"
- ninja install
-}