aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-06-25 19:13:13 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-06-25 19:13:13 +0200
commitc7270b9b0f0dbd44a6089e54665182c381f36015 (patch)
treeaa0c24def68f7848fd4abf8c2ae8d75f084ba861 /linux/makepkg/PKGBUILD
parentAdd ProfileManager (diff)
downloadsmolbote-c7270b9b0f0dbd44a6089e54665182c381f36015.tar.xz
Update pkgbuild
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index d0e3b7f..cd21909 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -14,7 +14,7 @@ replaces=('smolbote-git')
depends=('qt5-webengine>=5.10.1' 'boost-libs>=1.66.0')
optdepends=('firejail: launch a sandboxed instance')
-makedepends=('mercurial' 'cmake' 'pkg-config' 'ninja')
+makedepends=('mercurial' 'cmake' 'pkg-config' 'go-md2man')
# this is the central repository
source=("smolbote-hg::hg+https://neueland.iserlohn-fortress.net/smolbote.hg")
@@ -29,7 +29,7 @@ prepare() {
# go into src/smolbote-hg
cd smolbote-hg
- msg "Verifying integrity"
+ msg2 "Verifying integrity"
# get commit id
_node="$(hg log -r tip --template='{node}')"
# download checksums and signature
@@ -46,11 +46,13 @@ pkgver() {
}
build() {
+ # clean build folder
# src/smolbote-hg-r000.123456789012
rm -rf "$pkgname-$pkgver"
mkdir "$pkgname-$pkgver"
cd "$pkgname-$pkgver"
+ msg2 "Building smolbote"
# CMake Options
# Build Type
# Debug builds don't have install rules.
@@ -73,23 +75,22 @@ build() {
# this requires 'extra-cmake-modules'
#_cmake_options="$_cmake_options -DPlasma=On"
- # Build System
- # Flavour: I use ninja, but you can comment this out, or set your own
- # flavour. Don't forget to change the Build and Install though!
- _cmake_options="$_cmake_options -GNinja"
-
# Generate Makefile
cmake $_cmake_options "$srcdir/smolbote-hg"
# Build
- ninja
+ make
+
+ msg2 "Generating manpage"
+ go-md2man -in $srcdir/smolbote-hg/linux/man/smolbote.md -out smolbote.7
+ gzip smolbote.7
}
package() {
cd "$pkgname-$pkgver"
# Install
- ninja install
+ make install
# icon and .desktop
install -Dm644 "${srcdir}/smolbote-hg/data/poi.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/poi.svg"
@@ -99,7 +100,6 @@ package() {
install -Dm644 "${srcdir}/smolbote-hg/data/poi.profile" "${pkgdir}/usr/local/lib/smolbote/poi.profile"
# man page
- _man_dir="$pkgdir/usr/local/man/man7"
- test -d $_man_dir || mkdir -p $_man_dir
- gzip --keep --to-stdout "$srcdir/smolbote-hg/linux/man/smolbote.7" > "$_man_dir/smolbote.7.gz"
+ install -Dm644 smolbote.7.gz $pkgdir/usr/local/man/man7/smolbote.7.gz
}
+