aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-10-04 13:40:20 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-10-04 13:40:20 +0300
commite5809ca41c81750dbf59c2b170328df892a69e26 (patch)
treea9e4eff906ead096f97058ba80ed6869cb0db78a /meson.build
parentFix deprecated warning in meson.build (diff)
downloadsmolbote-e5809ca41c81750dbf59c2b170328df892a69e26.tar.xz
Remove outparam section in Configuration parse
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 73963a8..d12b130 100644
--- a/meson.build
+++ b/meson.build
@@ -30,7 +30,7 @@ endif
sourceset = import('sourceset')
cxx = meson.get_compiler('cpp')
-summary({'compiler': cxx.get_id()}, section: 'Compiler')
+summary({'id': cxx.get_id()}, section: 'Compiler')
# add some specific flags
add_project_arguments(cxx.get_supported_arguments([
@@ -67,7 +67,7 @@ add_project_arguments(cxx.get_supported_arguments([
'-Wlogical-op', # logical operations being used where bitwise were probably wanted
'-Wimplicit-fallthrough',
'-Wduplicated-cond', # if/else chain has duplicated conditions
- '-Wduplicated-brances', # if/else branches have duplicated code
+ '-Wduplicated-branches', # if/else branches have duplicated code
# casts
'-Wold-style-cast',
'-Wcast-align', # potential performance problem casts