aboutsummaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2019-10-13 18:25:49 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2019-10-13 18:25:49 +0300
commit22e4c0b2bfea51c9f48d0d84e527ffe4c8eb0e25 (patch)
tree296b8e0be37ffd3f46f1d66dcf7d3ffc6f0b6a8a /meson_options.txt
parentAdd some cpp compiler options and warnings (diff)
downloadsmolbote-22e4c0b2bfea51c9f48d0d84e527ffe4c8eb0e25.tar.xz
Improve meson.build files
- meson should now properly create OpenSSL signing key and hexdump before trying to compile plugin loader
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson_options.txt b/meson_options.txt
index 2615eaa..5f56ec2 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -2,6 +2,11 @@
option('poiName', description: 'Executable name', type: 'string', value: 'poi')
option('firejail', description: 'firejail executable name', type: 'string', value: '/usr/bin/firejail')
+# Build options
+option('signPlugins', description: 'Generate OpenSSL signing key', type: 'feature', value: 'auto')
+option('ssl_private_pem', description: 'OpenSSL private key path', type: 'string', value: 'privateKey.pem')
+option('ssl_public_pem', description: 'OpenSSL public key path', type: 'string', value: 'publicKey.pem')
+
# Install options
option('manpage', description: 'Generate and install manpage', type: 'feature', value: 'auto')
option('translations', description: 'Generate and install translations', type: 'feature', value: 'auto')