aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-09 12:05:28 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-09 12:05:28 +0200
commit3639d5789259561c531a3481d7061a0cb492c644 (patch)
treec9c7ff04022b62cf5be4d4ea31bf28d966ccefda /src/CMakeLists.txt
parentCreate .profile file when adding a new profile (diff)
downloadsmolbote-3639d5789259561c531a3481d7061a0cb492c644.tar.xz
Unlink plugins from lib/ libraries
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e8f2794..a44a44f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -47,8 +47,10 @@ set(srclist
webengine/webview.cpp
webengine/webview.h
- # plugin interfaces
- plugin.h
+ # interfaces
+ ${PROJECT_SOURCE_DIR}/include/plugininterface.h
+ ${PROJECT_SOURCE_DIR}/include/profileinterface.h
+ ${PROJECT_SOURCE_DIR}/include/browserinterface.h
)
# if you are using a custom build location for breakpad:
@@ -64,6 +66,7 @@ endif()
target_include_directories(${poi_exe}
PRIVATE ${Boost_INCLUDE_DIRS}
+ PRIVATE ${PROJECT_SOURCE_DIR}/include
PRIVATE ${PROJECT_SOURCE_DIR}/lib
PRIVATE ${PROJECT_SOURCE_DIR}/plugins
)