aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-06-16 09:46:48 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-06-16 09:46:48 +0200
commitb936bccd9d0d7f50f37c078b7aad9e75ee9fc981 (patch)
tree8387c8cbce8c4924a71fa34d7df124f8593a0e94 /src/CMakeLists.txt
parentBookmarks manager bugfixes (diff)
downloadsmolbote-b936bccd9d0d7f50f37c078b7aad9e75ee9fc981.tar.xz
Add Plasma option to cmake that turns on KF5 blur window effect
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0c6876d..cf66a53 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -58,7 +58,15 @@ target_link_libraries(poi
about
addressbar
configuration
- bookmarks downloads web)
+ bookmarks downloads web
+)
+
+if(Plasma)
+ target_link_libraries(poi KF5::WindowSystem)
+ target_compile_definitions(poi
+ PRIVATE PLASMA_BLUR # give the main window a translucent background and blur
+ )
+endif(Plasma)
target_compile_definitions(poi
PRIVATE QTBUG_65223_WORKAROUND