aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-04-16 17:07:36 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-04-16 17:07:36 +0200
commitd796821f8304306dbe088701724243b39e8eb358 (patch)
tree836c85aa421db5c495e2b36f6a02cea924b6d919 /src/CMakeLists.txt
parentBranch of Qt5.11 features (diff)
downloadsmolbote-d796821f8304306dbe088701724243b39e8eb358.tar.xz
Multiple subwindows interface
Subwindows are similar to tab groups. - Rewrote Browser and MainWindow, so they should be somewhat cleaner now - Moved AboutDialog to lib/about What's broken: - loading bar - search box - address bar bookmark suggestions - plugins
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt33
1 files changed, 13 insertions, 20 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0f978b5..8adb1aa 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -20,16 +20,17 @@ add_executable(poi
# main window
mainwindow/mainwindow.cpp
mainwindow/mainwindow.h
- mainwindow/mainwindow.ui
- mainwindow/widgets/loadingbar.cpp
- mainwindow/widgets/loadingbar.h
+ mainwindow/window.cpp
+ mainwindow/window.h
+ #mainwindow/widgets/loadingbar.cpp
+ #mainwindow/widgets/loadingbar.h
mainwindow/widgets/navigationbar.cpp
mainwindow/widgets/navigationbar.h
- mainwindow/widgets/searchform.cpp
- mainwindow/widgets/searchform.h
- mainwindow/widgets/searchform.ui
- mainwindow/widgets/tabbar.cpp
- mainwindow/widgets/tabbar.h
+ #mainwindow/widgets/searchform.cpp
+ #mainwindow/widgets/searchform.h
+ #mainwindow/widgets/searchform.ui
+ mainwindow/widgets/tabwidget.cpp
+ mainwindow/widgets/tabwidget.h
# address bar
addressbar/completer.cpp
@@ -37,15 +38,11 @@ add_executable(poi
addressbar/urllineedit.cpp
addressbar/urllineedit.h
- # todo: move all to mainwindow
- widgets/mainwindowmenubar.cpp
- widgets/mainwindowmenubar.h
-
# webengine
webengine/urlinterceptor.cpp
webengine/urlinterceptor.h
- webengine/webengineprofile.cpp # todo: rename to profile
- webengine/webengineprofile.h
+ webengine/webprofile.cpp
+ webengine/webprofile.h
webengine/webpage.cpp
webengine/webpage.h
webengine/webview.cpp
@@ -55,13 +52,8 @@ add_executable(poi
webengine/widgets/pagemenu.cpp
webengine/widgets/pagemenu.h
- # forms
- forms/aboutdialog.cpp
- forms/aboutdialog.h
- forms/aboutdialog.ui
-
# plugin interfaces
- ../plugins/interfaces.h
+ #../plugins/interfaces.h
)
target_include_directories(poi
@@ -70,6 +62,7 @@ target_include_directories(poi
target_link_libraries(poi
Qt5::Core Qt5::Widgets Qt5::Concurrent Qt5::WebEngineWidgets
+ about
configuration
bookmarks downloads)