aboutsummaryrefslogtreecommitdiff
path: root/src/cmd/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-12-07 12:22:15 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2020-12-07 12:22:15 +0200
commit92b3c2dcff3e85ad3d455f6ab845d9a97d3b525b (patch)
treea850643f7b86e6cebfddbeec98d7c372478d379c /src/cmd/CMakeLists.txt
parentHostlist filter plugin can rewrite hostnames (diff)
downloadsmolbote-92b3c2dcff3e85ad3d455f6ab845d9a97d3b525b.tar.xz
Rewrite meson build scripts into cmakelists
Diffstat (limited to 'src/cmd/CMakeLists.txt')
-rw-r--r--src/cmd/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/cmd/CMakeLists.txt b/src/cmd/CMakeLists.txt
new file mode 100644
index 0000000..31563c9
--- /dev/null
+++ b/src/cmd/CMakeLists.txt
@@ -0,0 +1,5 @@
+add_executable(cmd_test test.cpp)
+target_link_libraries(cmd_test PRIVATE autogen Qt5::Core)
+target_sanitize(cmd_test)
+
+add_test(NAME cmd_parser COMMAND cmd_test) \ No newline at end of file