aboutsummaryrefslogtreecommitdiff
path: root/src/webengine/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-12-15 11:51:08 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2020-12-15 15:23:12 +0200
commite9c6cdefff00daffb8b07e72c47f8e8f845ba436 (patch)
treefeb3ec54de25fd2c41ccc6dc1d586642a84babf9 /src/webengine/CMakeLists.txt
parentCode cleanup (diff)
downloadsmolbote-e9c6cdefff00daffb8b07e72c47f8e8f845ba436.tar.xz
Move src/webengine to lib/webengine
Diffstat (limited to 'src/webengine/CMakeLists.txt')
-rw-r--r--src/webengine/CMakeLists.txt22
1 files changed, 0 insertions, 22 deletions
diff --git a/src/webengine/CMakeLists.txt b/src/webengine/CMakeLists.txt
deleted file mode 100644
index 156c64a..0000000
--- a/src/webengine/CMakeLists.txt
+++ /dev/null
@@ -1,22 +0,0 @@
-add_library(webengine INTERFACE)
-target_sources(webengine INTERFACE
- webprofile.h webprofile.cpp webprofilemanager.h webprofilemanager.cpp
- webpage.h webpage.cpp
- webview.h webview.cpp webviewcontextmenu.h webviewcontextmenu.cpp
- urlinterceptor.h urlinterceptor.cpp)
-target_include_directories(webengine INTERFACE ${CMAKE_SOURCE_DIR}/include ${CMAKE_CURRENT_SOURCE_DIR})
-target_link_libraries(webengine INTERFACE Qt5::WebEngineWidgets autogen fmt)
-
-# tests
-add_executable(profile_test test/profile.cpp)
-target_link_libraries(profile_test PRIVATE webengine Catch2::Catch2)
-#target_sanitize(profile_test)
-
-add_executable(profilemanager_test test/profilemanager.cpp)
-target_link_libraries(profilemanager_test PRIVATE webengine Catch2::Catch2)
-#target_sanitize(profilemanager_test)
-
-add_test(NAME webengine_profile COMMAND profile_test)
-add_test(NAME webengine_profilemanager COMMAND profilemanager_test)
-set_tests_properties(webengine_profile webengine_profilemanager PROPERTIES
- ENVIRONMENT "PROFILE=${CMAKE_CURRENT_SOURCE_DIR}/test/testing.profile") \ No newline at end of file