aboutsummaryrefslogtreecommitdiff
path: root/staging/adblock/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-04-15 17:23:48 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-04-21 20:14:57 +0300
commitf5a067e505c442618dc59d962fd6fa5d6cf16ab8 (patch)
treef401b839240659b558c84643d977d10c7a3f0d4e /staging/adblock/meson.build
parentAdd tests for regex rules (diff)
downloadsmolbote-f5a067e505c442618dc59d962fd6fa5d6cf16ab8.tar.xz
Add some Options tests
Diffstat (limited to 'staging/adblock/meson.build')
-rw-r--r--staging/adblock/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/staging/adblock/meson.build b/staging/adblock/meson.build
index f0a0e07..fb92481 100644
--- a/staging/adblock/meson.build
+++ b/staging/adblock/meson.build
@@ -22,6 +22,12 @@ test('adblock: rule', executable('libadblockfilter_rule',
dependencies: [ dep_qt5, dep_catch ]
))
+test('adblock: options', executable('libadblockfilter_options',
+ sources: 'test/options.cpp',
+ link_with: lib_adblockfilter,
+ dependencies: [ dep_qt5, dep_catch ]
+))
+
test('adblock: filterlist', executable('libadblockfilter_filterlist',
sources: 'test/filterlist.cpp',
include_directories: smolbote_interfaces,