aboutsummaryrefslogtreecommitdiff
path: root/staging/adblock/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-02-10 20:58:39 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2020-05-30 11:01:35 +0300
commitd1287f43964633035938f4f4d4133bb6d9da7b3e (patch)
treed09efa4074815c20be9bd6348203fe4336dfe716 /staging/adblock/meson.build
parentFix segfault in release build (diff)
downloadsmolbote-d1287f43964633035938f4f4d4133bb6d9da7b3e.tar.xz
staging: smolblok
smolblok is a replacement for the current lib/urlfilter AdBlockPlus and hostlist format filter parser. It is a library that uses plugins to provide support for different filter formats. staging/adblock: AdBlockPlus parser plugin plugins/smolblok_hostlist: hostlist format parser plugin Headers will be installed to include/smolbote/ Remove lib/urlfilter
Diffstat (limited to 'staging/adblock/meson.build')
-rw-r--r--staging/adblock/meson.build38
1 files changed, 38 insertions, 0 deletions
diff --git a/staging/adblock/meson.build b/staging/adblock/meson.build
new file mode 100644
index 0000000..942f325
--- /dev/null
+++ b/staging/adblock/meson.build
@@ -0,0 +1,38 @@
+lib_adblockfilter = static_library('adblockfilter',
+ [ 'filterlist.cpp', 'options.cpp' ],
+ include_directories: smolbote_interfaces,
+ dependencies: [ dep_qt5 ]
+)
+
+dep_adblockfilter = declare_dependency(
+ include_directories: ['.', smolbote_interfaces],
+ link_with: lib_adblockfilter
+)
+
+#AdblockPlusFilterPlugin = shared_library('AdblockPlusPlugin',
+# [ 'plugin/plugin.cpp',
+# mod_qt5.preprocess(include_directories: smolbote_interfaces,
+# moc_headers: 'plugin/plugin.h', dependencies: dep_qt5)
+# ],
+# include_directories: smolbote_interfaces,
+# link_with: lib_adblockfilter,
+# dependencies: dep_qt5,
+# install: true,
+# install_dir: get_option('libdir')/'smolbote/plugins'
+#)
+
+test('adblock: rule', executable('libadblockfilter_rule',
+ sources: 'test/rule.cpp',
+ dependencies: [ dep_qt5, dep_catch, dep_adblockfilter ]
+))
+
+test('adblock: options', executable('libadblockfilter_options',
+ sources: 'test/options.cpp',
+ dependencies: [ dep_qt5, dep_catch, dep_adblockfilter ]
+))
+
+test('adblock: filterlist', executable('libadblockfilter_filterlist',
+ sources: 'test/filterlist.cpp',
+ dependencies: [ dep_qt5, dep_catch, dep_adblockfilter ]
+))
+