aboutsummaryrefslogtreecommitdiff
path: root/staging/filterlist/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-02-14 11:44:38 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2020-04-21 20:14:55 +0300
commitf0d67a082a0f28d7b4380d3b6a88f1041bfae8bb (patch)
tree3329e55f194cd2b2bf16def11e9c74b08fffd731 /staging/filterlist/meson.build
parentstaging: rewrite AdblockPlus parser yet again (diff)
downloadsmolbote-f0d67a082a0f28d7b4380d3b6a88f1041bfae8bb.tar.xz
staging: add filterlist parallel downloader
Diffstat (limited to 'staging/filterlist/meson.build')
-rw-r--r--staging/filterlist/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/staging/filterlist/meson.build b/staging/filterlist/meson.build
new file mode 100644
index 0000000..b8f2263
--- /dev/null
+++ b/staging/filterlist/meson.build
@@ -0,0 +1,15 @@
+dep_staging_utils = declare_dependency(
+ include_directories: include_directories('.'),
+ link_with: static_library('staging-utils',
+ [ 'downloadmanager.cpp',
+ mod_qt5.preprocess(moc_headers: 'downloadmanager.h')
+ ],
+ dependencies: dep_qt5
+ )
+)
+
+executable('filterlist',
+ dependencies: [ dep_qt5, dep_staging_utils ],
+ sources: [ 'test/main.cpp' ]
+)
+