aboutsummaryrefslogtreecommitdiff
path: root/staging/hostlist/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-04-20 13:29:06 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-04-21 20:14:58 +0300
commit8d484d153dd054be89be51b7b4e9815450c0065a (patch)
tree44a4c1045969909197312003957611f90d9be582 /staging/hostlist/meson.build
parentAdd plugin loading code to smolblok (diff)
downloadsmolbote-8d484d153dd054be89be51b7b4e9815450c0065a.tar.xz
Move staging/hostlist to subprojects/plugin_hostlist
Diffstat (limited to 'staging/hostlist/meson.build')
-rw-r--r--staging/hostlist/meson.build20
1 files changed, 0 insertions, 20 deletions
diff --git a/staging/hostlist/meson.build b/staging/hostlist/meson.build
deleted file mode 100644
index c5f3499..0000000
--- a/staging/hostlist/meson.build
+++ /dev/null
@@ -1,20 +0,0 @@
-lib_hostlistfilter = static_library('hostlistfilter',
- [ 'filterlist.cpp' ],
- include_directories: smolbote_interfaces,
- dependencies: [dep_qt5]
-)
-
-dep_hostlistfilter = declare_dependency(
- include_directories: ['.', smolbote_interfaces],
- link_with : lib_hostlistfilter
-)
-
-test('hostlist: rule parsing', executable('rule',
- sources: 'test/rule.cpp',
- dependencies: [dep_qt5, dep_catch, dep_hostlistfilter]))
-
-test('hostlist: filterlist', executable('filterlist',
- sources: 'test/filterlist.cpp',
- dependencies: [dep_qt5, dep_catch, dep_hostlistfilter]),
- env: 'HOSTLIST_TXT='+meson.current_source_dir()/'test/hostlist.txt'
-)