aboutsummaryrefslogtreecommitdiff
path: root/staging/hostlist/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-04-18 15:06:35 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-04-21 20:14:57 +0300
commita35b365504c51d4c8e605e5586438deb93ad6d63 (patch)
tree21db39c787afc0bc70c0325a6c519cabb9761611 /staging/hostlist/meson.build
parentsmolblok: rewrite filtermanager (diff)
downloadsmolbote-a35b365504c51d4c8e605e5586438deb93ad6d63.tar.xz
Add staging/hostlist
Diffstat (limited to 'staging/hostlist/meson.build')
-rw-r--r--staging/hostlist/meson.build36
1 files changed, 36 insertions, 0 deletions
diff --git a/staging/hostlist/meson.build b/staging/hostlist/meson.build
new file mode 100644
index 0000000..d37db1b
--- /dev/null
+++ b/staging/hostlist/meson.build
@@ -0,0 +1,36 @@
+lib_hostlistfilter = static_library('hostlistfilter',
+ ['filterlist.cpp'],
+ include_directories
+ : smolbote_interfaces,
+ dependencies
+ : [dep_qt5])
+
+ dep_hostlistfilter
+ = declare_dependency(
+ include_directories
+ : ['.', smolbote_interfaces],
+ link_with
+ : lib_hostlistfilter)
+
+#AdblockPlusFilterPlugin = shared_library('AdblockPlusPlugin',
+#['plugin/plugin.cpp',
+#mod_qt5.preprocess(include_directories \
+ : smolbote_interfaces,
+#moc_headers : 'plugin/plugin.h', dependencies : dep_qt5)
+#],
+#include_directories : smolbote_interfaces,
+#link_with : lib_adblockfilter,
+#dependencies : dep_qt5,
+#install : true,
+#install_dir : get_option('libdir') / 'smolbote/plugins'
+#)
+
+ test('hostlist: rule parsing', executable('rule', sources
+ : 'test/rule.cpp', dependencies
+ : [dep_qt5, dep_catch, dep_hostlistfilter]))
+
+ subdir_done()
+
+ test('hostlist: filterlist', executable('filterlist', sources
+ : 'test/filterlist.cpp', dependencies
+ : [dep_qt5, dep_catch, dep_hostlistfilter]))