aboutsummaryrefslogtreecommitdiff
path: root/subprojects/plugin_hostlist/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2020-04-23 16:50:01 +0300
committerAqua-sama <aqua@iserlohn-fortress.net>2020-04-23 16:50:01 +0300
commit54cc702419163c416e5511f487fcb80cb37b2561 (patch)
treec93ef759f2973bb4149b806ee4da055a749a5222 /subprojects/plugin_hostlist/meson.build
parentRemove plugin_hostlist:interface (diff)
downloadsmolbote-54cc702419163c416e5511f487fcb80cb37b2561.tar.xz
plugin_hostlist: add fuzzer
Diffstat (limited to 'subprojects/plugin_hostlist/meson.build')
-rw-r--r--subprojects/plugin_hostlist/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/subprojects/plugin_hostlist/meson.build b/subprojects/plugin_hostlist/meson.build
index 04711fd..f4178c9 100644
--- a/subprojects/plugin_hostlist/meson.build
+++ b/subprojects/plugin_hostlist/meson.build
@@ -40,3 +40,14 @@ test('filterlist', executable('filterlist',
dependencies: [dep_qt5, dep_catch, dep_hostlistfilter]),
env: 'HOSTLIST_TXT='+meson.current_source_dir()/'test/hostlist.txt'
)
+
+# fuzzer
+if meson.get_compiler('cpp').has_multi_arguments('-g', '-fsanitize=fuzzer')
+executable('hostlist-fuzzer',
+ sources: 'filterlist.cpp',
+ include_directories: smolbote_interface,
+ dependencies: dep_qt5,
+ cpp_args: [ '-g', '-fsanitize=fuzzer', '-DFUZZER' ],
+ link_args: [ '-fsanitize=fuzzer' ]
+)
+endif