aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-04-08 14:52:40 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-04-08 14:52:40 +0200
commitbadceb8dfa8b54ff6da55e9a2188da53ad1aa8e8 (patch)
tree5332436d7e74723db680d7430adf3b483e3daaae /test/CMakeLists.txt
parentAdd FeatureSummary to CMakeLists (diff)
downloadsmolbote-badceb8dfa8b54ff6da55e9a2188da53ad1aa8e8.tar.xz
Multithreading UrlRequestInterceptor
- Add parse() free function to UrlRequestInterceptor - hostlists are loaded in parallel via QtConcurrent
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..29c95ff
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,17 @@
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+
+macro(create_test testname)
+ add_executable(${testname}
+ ${testname}.cpp ${testname}.h
+ autotests.qrc
+ ${ARGN})
+
+ target_include_directories(${testname} PRIVATE ../src)
+ target_link_libraries(${testname} Qt5::Test Qt5::Concurrent Qt5::WebEngineWidgets)
+
+ add_test(NAME smolbote-${testname} COMMAND ${testname})
+endmacro()
+
+create_test(HostlistTest ../src/webengine/urlinterceptor.cpp ../src/webengine/urlinterceptor.h) \ No newline at end of file