aboutsummaryrefslogtreecommitdiff
path: root/test/meson.build
diff options
context:
space:
mode:
authorAqua-sama <aqua@iserlohn-fortress.net>2018-10-25 16:57:20 +0200
committerAqua-sama <aqua@iserlohn-fortress.net>2018-10-25 16:57:20 +0200
commit9486e7f6c3394178bd886ebc9189835ab60221a8 (patch)
treebcd0231440692ec6b99446099adc0f463f5e707f /test/meson.build
parentRemove breakpad gitmodule (diff)
downloadsmolbote-9486e7f6c3394178bd886ebc9189835ab60221a8.tar.xz
Add test/ meson.build
Diffstat (limited to 'test/meson.build')
-rw-r--r--test/meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/test/meson.build b/test/meson.build
new file mode 100644
index 0000000..3849f07
--- /dev/null
+++ b/test/meson.build
@@ -0,0 +1,27 @@
+# Adblock parsing test
+adblock = executable('AdblockTest',
+ dependencies: [dep_qt5, dep_urlfilter],
+ sources: ['adblock/adblocktest.cpp', qt5.preprocess(moc_headers: 'adblock/adblocktest.h', dependencies: dep_qt5)]
+)
+test('urlfilter-adblock', adblock)
+
+# Hostlist parsing test
+hostlist = executable('HostlistTest',
+ dependencies: [dep_qt5, dep_urlfilter],
+ sources: ['hostlist/hostlisttest.cpp', qt5.preprocess(moc_headers: 'hostlist/hostlisttest.h', dependencies: dep_qt5)]
+)
+test('urlfilter-hostlist', hostlist)
+
+# matching algorithms benchmark
+matcherbenchmark = executable('MatcherBenchmark',
+ dependencies: dep_qt5,
+ sources: ['matcherbenchmark/matcherbenchmark.cpp', qt5.preprocess(moc_headers: 'matcherbenchmark/matcherbenchmark.h', dependencies: dep_qt5)]
+)
+
+# SingleApplication issue#40 test app
+singleapp = executable('SingleApplication',
+ cpp_args: ['-DQAPPLICATION_CLASS=QApplication'],
+ dependencies: [dep_qt5, dep_SingleApplication],
+ sources: ['singleapplication-40/main.cpp']
+)
+