aboutsummaryrefslogtreecommitdiff
path: root/config/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'config/CMakeLists.txt')
-rw-r--r--config/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/config/CMakeLists.txt b/config/CMakeLists.txt
new file mode 100644
index 0000000..129b2f2
--- /dev/null
+++ b/config/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 3.1.0)
+
+# Find includes in corresponding build directories
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+add_executable(poi-config
+ main.cpp
+ settingsdialog.cpp
+ settingsdialog.h
+ ../src/configuration.h
+ ../src/configuration.cpp
+ )
+
+target_link_libraries(poi-config Qt5::Core Qt5::Widgets)
+target_link_libraries(poi-config ${Boost_LIBRARIES})