aboutsummaryrefslogtreecommitdiff
path: root/config/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'config/CMakeLists.txt')
-rw-r--r--config/CMakeLists.txt26
1 files changed, 0 insertions, 26 deletions
diff --git a/config/CMakeLists.txt b/config/CMakeLists.txt
deleted file mode 100644
index 7ee13b0..0000000
--- a/config/CMakeLists.txt
+++ /dev/null
@@ -1,26 +0,0 @@
-# Find includes in corresponding build directories
-set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
-# Instruct CMake to run moc automatically when needed.
-set(CMAKE_AUTOMOC ON)
-set(CMAKE_AUTOUIC ON)
-set(CMAKE_AUTORCC ON)
-
-add_executable(poi-config
- main.cpp
- settingsdialog.cpp
- settingsdialog.h
-)
-
-target_include_directories(poi-config
- PRIVATE ../lib/configuration
- PRIVATE ${Boost_INCLUDE_DIRS}
-)
-
-target_link_libraries(poi-config
- Qt5::Core Qt5::Widgets
- ${Boost_LIBRARIES}
- configuration
-)
-
-install(TARGETS poi-config RUNTIME DESTINATION bin CONFIGURATIONS Release)