aboutsummaryrefslogtreecommitdiff
path: root/config/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'config/CMakeLists.txt')
-rw-r--r--config/CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/config/CMakeLists.txt b/config/CMakeLists.txt
index cde4648..9ae0381 100644
--- a/config/CMakeLists.txt
+++ b/config/CMakeLists.txt
@@ -10,12 +10,15 @@ add_executable(poi-config
main.cpp
settingsdialog.cpp
settingsdialog.h
- ../src/configuration.h
- ../src/configuration.cpp
- )
+)
+
+target_include_directories(poi-config
+ PRIVATE ../lib/configuration
+)
target_link_libraries(poi-config
Qt5::Core Qt5::Widgets
- ${Boost_LIBRARIES})
+ configuration
+)
install(TARGETS poi-config RUNTIME DESTINATION bin CONFIGURATIONS Release)