aboutsummaryrefslogtreecommitdiff
path: root/doc/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/meson.build')
-rw-r--r--doc/meson.build70
1 files changed, 42 insertions, 28 deletions
diff --git a/doc/meson.build b/doc/meson.build
index d45aea1..868b8d5 100644
--- a/doc/meson.build
+++ b/doc/meson.build
@@ -1,28 +1,42 @@
-if get_option('manpage').enabled()
- asciidoctor = find_program('asciidoctor', required: true)
-
- custom_target('manpage',
- # list depend_files so the output can be updated if any of them are changed
- depend_files: ['smolbote.7.asciidoc', 'Usage/CommandLine.asciidoc', 'Usage/Configuration.asciidoc', 'Usage/Profile.asciidoc', 'Usage/Plugins.asciidoc', 'Usage/Filter.asciidoc'],
- input: 'smolbote.7.asciidoc',
- output: 'smolbote.7',
- command: [asciidoctor, '--backend=manpage', '--out-file=@OUTPUT@', '@INPUT@'],
- build_by_default: true,
- install: true, install_dir: join_paths(get_option('mandir'), 'man7')
- )
-
- custom_target('manpage.5',
- # list of files this target depends on
- depend_files: ['smolbote.5.asciidoc'],
-
- input: 'smolbote.5.asciidoc',
- output: 'smolbote.5',
-
- command: [asciidoctor, '--backend=manpage', '--out-file=@OUTPUT@', '@INPUT@'],
-
- build_by_default: true,
- install: true,
- install_dir: get_option('mandir') / 'man5'
- )
-
-endif
+asciidoctor = find_program('asciidoctor', required: get_option('manpage'))
+
+custom_target('manpage.7',
+ # list depend_files so the output can be updated if any of them are changed
+ depend_files: ['smolbote.7.asciidoc', 'Usage/CommandLine.asciidoc', 'Usage/Configuration.asciidoc', 'Usage/Profile.asciidoc', 'Usage/Plugins.asciidoc', 'Usage/Filter.asciidoc'],
+
+ input: 'smolbote.7.asciidoc',
+ output: 'smolbote.7',
+
+ command: [asciidoctor, '--backend=manpage', '--out-file=@OUTPUT@', '@INPUT@'],
+
+ build_by_default: get_option('manpage').enabled(),
+ install: get_option('manpage').enabled(),
+ install_dir: join_paths(get_option('mandir'), 'man7')
+)
+
+custom_target('manpage.5',
+ # list of files this target depends on
+ depend_files: ['smolbote.5.asciidoc'],
+
+ input: 'smolbote.5.asciidoc',
+ output: 'smolbote.5',
+
+ command: [asciidoctor, '--backend=manpage', '--out-file=@OUTPUT@', '@INPUT@'],
+
+ build_by_default: get_option('manpage').enabled(),
+ install: get_option('manpage').enabled(),
+ install_dir: get_option('mandir') / 'man5'
+)
+
+custom_target('manual',
+ depend_files: ['smolbote.asciidoc'],
+
+ input: 'smolbote.asciidoc',
+ output: 'manual.html',
+
+ command: [asciidoctor, '-a', 'imagesdir=images', '--out-file=@OUTPUT@', '@INPUT@'],
+
+ build_by_default: false,
+ install: false
+)
+