aboutsummaryrefslogtreecommitdiff
path: root/lib/bookmarks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/bookmarks/CMakeLists.txt')
-rw-r--r--lib/bookmarks/CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/lib/bookmarks/CMakeLists.txt b/lib/bookmarks/CMakeLists.txt
index b7bbf0d..d2256c6 100644
--- a/lib/bookmarks/CMakeLists.txt
+++ b/lib/bookmarks/CMakeLists.txt
@@ -14,8 +14,16 @@ add_library(bookmarks
bookmarksview.h
# xbel
xbel.cpp
- xbel.h)
+ xbel.h
-target_include_directories(bookmarks
- PRIVATE ${CMAKE_CURRENT_SOURCE_DIR})
-target_link_libraries(bookmarks Qt5::Widgets) \ No newline at end of file
+ # bookmark item/model/view
+ bookmarkitem.cpp
+ bookmarkitem.h
+ bookmarkmodel.cpp
+ bookmarkmodel.h
+ forms/editbookmarkdialog.cpp
+ forms/editbookmarkdialog.h
+ forms/editbookmarkdialog.ui
+)
+
+target_link_libraries(bookmarks Qt5::Widgets)