aboutsummaryrefslogtreecommitdiff
path: root/lib/downloads/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/downloads/CMakeLists.txt')
-rw-r--r--lib/downloads/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/downloads/CMakeLists.txt b/lib/downloads/CMakeLists.txt
new file mode 100644
index 0000000..984d332
--- /dev/null
+++ b/lib/downloads/CMakeLists.txt
@@ -0,0 +1,6 @@
+add_library(downloads
+ downloadswidget.h downloadswidget.cpp downloadsform.ui
+ widgets/downloaditemwidget.h widgets/downloaditemwidget.cpp widgets/downloaditemform.ui
+ widgets/elidedlabel.h widgets/elidedlabel.cpp)
+target_link_libraries(downloads PUBLIC Qt5::WebEngineWidgets)
+target_include_directories(downloads PUBLIC .)