aboutsummaryrefslogtreecommitdiff
path: root/lib/webengine/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/webengine/CMakeLists.txt')
-rw-r--r--lib/webengine/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/lib/webengine/CMakeLists.txt b/lib/webengine/CMakeLists.txt
new file mode 100644
index 0000000..ba3017f
--- /dev/null
+++ b/lib/webengine/CMakeLists.txt
@@ -0,0 +1,22 @@
+add_library(webengine STATIC
+ webprofile.h webprofile.cpp webprofilemanager.h webprofilemanager.cpp
+ webpage.h webpage.cpp
+ webview.h webview.cpp webviewcontextmenu.h webviewcontextmenu.cpp
+ urlinterceptor.h urlinterceptor.cpp)
+target_include_directories(webengine PUBLIC ${CMAKE_SOURCE_DIR}/include ${CMAKE_CURRENT_SOURCE_DIR})
+# autogen: required for context menu icons; TODO: move context menu to src/
+target_link_libraries(webengine PUBLIC Qt5::WebEngineWidgets autogen fmt)
+
+# tests
+add_executable(profile_test test/profile.cpp)
+target_link_libraries(profile_test PRIVATE webengine Catch2::Catch2)
+#target_sanitize(profile_test)
+
+add_executable(profilemanager_test test/profilemanager.cpp)
+target_link_libraries(profilemanager_test PRIVATE webengine Catch2::Catch2)
+#target_sanitize(profilemanager_test)
+
+add_test(NAME webengine_profile COMMAND profile_test)
+add_test(NAME webengine_profilemanager COMMAND profilemanager_test)
+set_tests_properties(webengine_profile webengine_profilemanager PROPERTIES
+ ENVIRONMENT "PROFILE=${CMAKE_CURRENT_SOURCE_DIR}/test/testing.profile")