aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD25
1 files changed, 10 insertions, 15 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 9243405..debf2f1 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -2,8 +2,7 @@
pkgname=smolbote-git
pkgdesc='Yet another no-frills browser'
-
-pkgver=r0
+pkgver=0
pkgrel=1
url="https://neueland.iserlohn-fortress.net/gitea/smolbote"
@@ -16,7 +15,7 @@ depends=('qt5-webengine>=5.11.0' 'spdlog')
optdepends=('firejail: launch a sandboxed instance')
makedepends=('git' 'meson' 'python-kconfiglib' 'openssl' 'qt5-tools' 'scdoc')
-# this is the central repository
+# use git+file:///path/to/your/repo to build from a local repo
source=("git+https://neueland.iserlohn-fortress.net/gitea/aqua/smolbote.git"
"git+https://github.com/itay-grudev/SingleApplication.git"
"git+https://github.com/Taywee/args")
@@ -25,14 +24,9 @@ sha512sums=('SKIP'
'SKIP'
'SKIP')
-#validgpgkeys=(# Aqua-sama <aqua@iserlohn-fortress.net>
-# BB1C090188E3E32B375C13FD095DE26BC16D2E98)
+#validgpgkeys=(BB1C090188E3E32B375C13FD095DE26BC16D2E98) # Aqua-sama <aqua@iserlohn-fortress.net>
## Build Options
-
-# Run menuconfig
-#_menuconfig=
-
# Enable plugin signing:
# meson/ninja will generate the privateKey.pem and publicKey.pem in the $builddir
# Because this embeds the public key into the executable, enabling this option will break reproducible builds.
@@ -52,9 +46,6 @@ pkgver() {
cd smolbote
# Without version tag
echo r$(git rev-list --count HEAD)-$(git rev-parse --short HEAD) | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-
- # With version tag
- #git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
@@ -72,17 +63,21 @@ build() {
# --auto-features=disabled - features should be explicitly enabled
# b_pie: Build executables as position independent
# b_lto: Use link time optimization
- meson --buildtype=plain --prefix=/usr/local --auto-features=disabled \
+ meson --buildtype=plain --wrap-mode=nodownload \
+ --prefix=/usr/local --auto-features=disabled \
-Db_pie=true -Db_lto=true -Dcpp_link_args="-fuse-ld=gold" \
-Dmanpage=enabled \
$srcdir/build
+ # uncomment to enable crashhandler
+ #meson configure -Dcrashhandler=enabled $srcdir/build
+ #KCONFIG_CONFIG=linux/.config setconfig USEBREAKPAD=y
+
# Run menuconfig
#KCONFIG_CONFIG=linux/.config menuconfig
# Build
- cd $srcdir/build
- ninja
+ ninja -C $srcdir/build
}
package() {