aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 78549c3..b7086ad 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -20,7 +20,7 @@ arch=('x86_64' 'aarch64')
license=('GPL3')
depends=('qt5-webengine>=5.11.0' 'spdlog')
-makedepends=('git' 'meson' 'python-kconfiglib' 'openssl' 'qt5-tools' 'scdoc')
+makedepends=('git' 'meson' 'python-kconfiglib' 'openssl' 'qt5-tools' 'scdoc' 'catch2')
if [ $_enableBreakpad == "1" ]; then
makedepends+=('breakpad-git')
fi
@@ -76,7 +76,7 @@ build() {
# b_lto: Use link time optimization
meson --buildtype=release --wrap-mode=nodownload \
--prefix=$_prefix --auto-features=disabled \
- -Db_pie=true \
+ -Db_pie=true -Ddefault_library=static \
-Dmanpage=enabled \
$srcdir/build