aboutsummaryrefslogtreecommitdiff
path: root/linux/makepkg/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'linux/makepkg/PKGBUILD')
-rw-r--r--linux/makepkg/PKGBUILD36
1 files changed, 14 insertions, 22 deletions
diff --git a/linux/makepkg/PKGBUILD b/linux/makepkg/PKGBUILD
index 5e27542..5bcf684 100644
--- a/linux/makepkg/PKGBUILD
+++ b/linux/makepkg/PKGBUILD
@@ -19,20 +19,15 @@ install="smolbote.install"
arch=('x86_64' 'aarch64')
license=('GPL3')
-depends=('qt5-webengine>=5.11.0' 'spdlog')
+depends=('qt5-svg' 'qt5-webengine>=5.11.0' 'spdlog')
makedepends=('git' 'meson' 'python-kconfiglib' 'openssl' 'qt5-tools' 'scdoc' 'catch2')
if [ $_enableBreakpad == "1" ]; then
makedepends+=('breakpad-git')
fi
optdepends=('firejail: launch a sandboxed instance')
-# this isn't a hard requirement, simply a workaround as the build script
-# sets some additional hardening flags that the default makepkg.conf
-# will turn down
-options=(!buildflags)
-
# use git+file:///path/to/your/repo to build from a local repo
-source=("git+https://library.iserlohn-fortress.net/aqua/smolbote.git"
+source=("git+https://neueland.iserlohn-fortress.net/cgit/smolbote"
"https://neueland.iserlohn-fortress.net/releases/SingleApplication-3.1.1a.tar.xz"{,.sig}
"https://neueland.iserlohn-fortress.net/releases/args.hxx-6.2.2.tar.xz"{,.sig})
@@ -48,6 +43,9 @@ prepare() {
mkdir "$srcdir/smolbote/subprojects/packagecache/"
ln -s "$srcdir/SingleApplication-3.1.1a" "$srcdir/smolbote/subprojects/"
ln -s "$srcdir/args.hxx-6.2.2" "$srcdir/smolbote/subprojects/"
+
+ cd $srcdir/smolbote
+ KCONFIG_CONFIG=linux/.config alldefconfig
}
pkgver() {
@@ -58,11 +56,8 @@ pkgver() {
build() {
mkdir -p $srcdir/build
- cd $srcdir/smolbote
- KCONFIG_CONFIG=linux/.config alldefconfig
- # For a list of configureable options, check smolbote/meson_options.txt, or
- # run `meson configure` in $srcdir/build
+ # For a list of configureable options, check smolbote/meson_options.txt, or run `meson configure` in $srcdir/build
# --wrap-mode=nodownload - disable meson from downloading dependency wraps. This will cause it to fail if makedepends are not found by pkg-config or cmake.
# --wrap-mode=nofallback - disable downloads as a fallback too. Implies --wrap-mode=nodownload
@@ -71,11 +66,11 @@ build() {
# --auto-features=disabled - features should be explicitly enabled
# b_pie: Build executables as position independent
# b_lto: Use link time optimization
- meson --buildtype=release --wrap-mode=nodownload \
- --prefix=$_prefix --auto-features=disabled \
+ meson setup \
+ --buildtype=plain --prefix=$_prefix --wrap-mode=nodownload --auto-features=disabled \
-Db_pie=true -Ddefault_library=static \
- -Dmanpage=enabled \
- $srcdir/build
+ -Dmanpage=true \
+ $srcdir/smolbote $srcdir/build
if [ $_enableBreakpad == "1" ]; then
msg2 "Enabling crashhandler"
@@ -83,16 +78,13 @@ build() {
KCONFIG_CONFIG=linux/.config setconfig USEBREAKPAD=y
fi
- # Run menuconfig
- #KCONFIG_CONFIG=linux/.config menuconfig
-
# Build
- ninja -C $srcdir/build "$MAKEFLAGS"
+ ninja -C $srcdir/build
}
-check() {
- ninja -C $srcdir/build test
-}
+#check() {
+# ninja -C $srcdir/build test
+#}
package() {
# Install