aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 1dd1a1f..272cb60 100644
--- a/meson.build
+++ b/meson.build
@@ -55,7 +55,7 @@ add_project_arguments(cxx.get_supported_arguments([
'-Wshadow', # if variable declaration shadows one from a parent context
# functions
'-Wnon-virtual-dtor', # if class with virtual functions has non-virtual dtor
- '-Werror=missing-declarations', # missing function declarations in header files
+ '-Wmissing-declarations', # missing function declarations in header files
'-Werror=redundant-decls',
'-Woverloaded-virtual', # warn if you overload (not override) a virtual function
'-Werror=return-type',
@@ -95,7 +95,6 @@ dep_spdlog = dependency('spdlog', fallback: ['spdlog', 'spdlog_dep'], version: '
dep_gtest = dependency('gtest', required: false, disabler: true)
dep_catch = dependency('catch2', required: true, fallback: ['catch2', 'catch2_dep'] )
dep_SingleApplication = dependency('singleapplication', fallback: [ 'singleapplication', 'SingleApplication_dep' ])
-dep_args = dependency('args.hxx', fallback: [ 'args', 'args_dep' ])
# Generate config header
poi_sourceset = sourceset.source_set()
@@ -113,7 +112,6 @@ subdir('lib/smolblok')
subdir('src')
subdir('lang')
subdir('doc')
-subdir('tools')
subdir('plugins/ProfileEditor')
subdir('plugins/HostlistFilter')
@@ -127,7 +125,7 @@ poi_exe = executable(get_option('poi'),
cpp_args: ['-DQAPPLICATION_CLASS=QApplication'],
sources: [ssconfig.sources()],
include_directories: [ plugininterfaces_include, include_directories('src') ],
- dependencies: [ dep_qt5, dep_spdlog, dep_SingleApplication, dep_args, dep_bookmarks, dep_configuration, dep_downloads, dep_pluginloader, ssconfig.dependencies(), lib_session_formats ],
+ dependencies: [ dep_qt5, dep_spdlog, dep_SingleApplication, dep_bookmarks, dep_configuration, dep_downloads, dep_pluginloader, ssconfig.dependencies(), lib_session_formats ],
install: true,
)