aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2ae2941..1dd1a1f 100644
--- a/meson.build
+++ b/meson.build
@@ -30,7 +30,11 @@ endif
sourceset = import('sourceset')
cxx = meson.get_compiler('cpp')
-summary({'id': cxx.get_id()}, section: 'Compiler')
+summary({
+ 'id': cxx.get_id(),
+ 'version': cxx.version(),
+ 'linker': cxx.get_linker_id(),
+}, section: 'Compiler')
# add some specific flags
add_project_arguments(cxx.get_supported_arguments([