aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 5 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 8290125..926fe8b 100644
--- a/meson.build
+++ b/meson.build
@@ -89,9 +89,6 @@ dep_qt5 = dependency('qt5',
dep_spdlog = dependency('spdlog', fallback: ['spdlog', 'spdlog_dep'], version: '>=1.3.1')
-optional_deps = []
-poi_cpp_args = []
-
dep_breakpad = dependency('breakpad-client', include_type: 'system', required: get_option('crashhandler'))
dep_threads = dependency('threads', include_type: 'system', required: get_option('crashhandler'))
@@ -111,6 +108,7 @@ subdir('lib/configuration')
subdir('lib/downloads')
subdir('lib/pluginloader')
subdir('lib/session_formats')
+subdir('lib/smolblok')
subdir('src')
subdir('lang')
@@ -118,20 +116,18 @@ subdir('doc')
subdir('tools')
subdir('plugins/ProfileEditor')
+subdir('plugins/HostlistFilter')
+subdir('plugins/AdblockFilter')
subdir('test/firefox-bookmarks-json-parser')
-subdir('test/matcherbenchmark')
-
-subdir('staging/smolblok')
-subdir('plugins/smolblok_hostlist')
ssconfig = poi_sourceset.apply(cdata)
poi_exe = executable(get_option('poi'),
- cpp_args: ['-DQAPPLICATION_CLASS=QApplication', poi_cpp_args],
+ cpp_args: ['-DQAPPLICATION_CLASS=QApplication'],
sources: [ssconfig.sources()],
include_directories: [ plugininterfaces_include, include_directories('src') ],
- dependencies: [ dep_qt5, dep_spdlog, dep_SingleApplication, dep_args, optional_deps, dep_bookmarks, dep_configuration, dep_downloads, dep_pluginloader, ssconfig.dependencies(), lib_session_formats ],
+ dependencies: [ dep_qt5, dep_spdlog, dep_SingleApplication, dep_args, dep_bookmarks, dep_configuration, dep_downloads, dep_pluginloader, ssconfig.dependencies(), lib_session_formats ],
install: true,
)