aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 3424554..08899fc 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('smolbote', ['cpp'],
version: '0.1.0',
- default_options: ['cpp_std=c++17', 'warning_level=3'],
+ default_options: ['cpp_std=c++2a', 'warning_level=3'],
license: 'GPL3',
meson_version: '>=0.52.0'
)
@@ -31,6 +31,7 @@ add_project_arguments(cxx.get_supported_arguments([
'-ffunction-sections', # Place each function into its own section, better ASLR but larger executables
'-fstack-protector-all', # Emit code to check for buffer overflows on all functions
'-fstack-clash-protection', # Emit code to check for stack clash attacks
+ '-fconcepts',
'-mspeculative-load-hardening', # Spectre v1 mitigation
@@ -90,7 +91,6 @@ subdir('tools')
#subdir('plugins/ConfigurationEditor')
#subdir('plugins/ProfileEditor')
-subdir('test/conf')
subdir('test/firefox-bookmarks-json-parser')
ssconfig = poi_sourceset.apply(cdata)