aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build26
1 files changed, 16 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index 56e50e7..8290125 100644
--- a/meson.build
+++ b/meson.build
@@ -2,18 +2,24 @@ project('smolbote', ['cpp'],
version: '0.1.0',
default_options: ['cpp_std=c++2a', 'warning_level=3'],
license: 'GPL3',
- meson_version: '>=0.52.0'
+ meson_version: '>=0.53.0'
)
+summary({
+ 'prefix': get_option('prefix'),
+ 'bindir': get_option('bindir'),
+ 'libdir': get_option('libdir'),
+ 'datadir': get_option('datadir')
+}, section: 'Install locations')
+
kconfig = import('unstable-kconfig')
kconf = kconfig.load(host_machine.system() + '/.config')
-
cdata = configuration_data(kconf)
version_h = vcs_tag(
command: [find_program('git').path(), 'describe', '--long', '--abbrev=40'],
#fallback: defaults to meson.project_version(),
- input: 'include/version.h.in',
+ input: 'src/version.h.in',
output: 'version.h'
)
@@ -88,9 +94,6 @@ poi_cpp_args = []
dep_breakpad = dependency('breakpad-client', include_type: 'system', required: get_option('crashhandler'))
dep_threads = dependency('threads', include_type: 'system', required: get_option('crashhandler'))
-if dep_breakpad.found()
- poi_cpp_args += '-DHAVE_BREAKPAD'
-endif
dep_gtest = dependency('gtest', required: false, disabler: true)
dep_catch = dependency('catch2', required: true, fallback: ['catch2', 'catch2_dep'] )
@@ -98,16 +101,15 @@ dep_SingleApplication = dependency('singleapplication', fallback: [ 'singleappli
dep_args = dependency('args.hxx', fallback: [ 'args', 'args_dep' ])
# Generate config header
-
poi_sourceset = sourceset.source_set()
-subdir('include') # plugin interaces
+subdir('include')
+smolbote_interfaces = include_directories('include')
subdir('lib/bookmarks')
subdir('lib/configuration')
subdir('lib/downloads')
subdir('lib/pluginloader')
-subdir('lib/urlfilter')
subdir('lib/session_formats')
subdir('src')
@@ -118,6 +120,10 @@ subdir('tools')
subdir('plugins/ProfileEditor')
subdir('test/firefox-bookmarks-json-parser')
+subdir('test/matcherbenchmark')
+
+subdir('staging/smolblok')
+subdir('plugins/smolblok_hostlist')
ssconfig = poi_sourceset.apply(cdata)
@@ -125,7 +131,7 @@ poi_exe = executable(get_option('poi'),
cpp_args: ['-DQAPPLICATION_CLASS=QApplication', poi_cpp_args],
sources: [ssconfig.sources()],
include_directories: [ plugininterfaces_include, include_directories('src') ],
- dependencies: [ dep_qt5, dep_spdlog, dep_SingleApplication, dep_args, optional_deps, dep_bookmarks, dep_configuration, dep_downloads, dep_pluginloader, dep_urlfilter, ssconfig.dependencies(), lib_session_formats ],
+ dependencies: [ dep_qt5, dep_spdlog, dep_SingleApplication, dep_args, optional_deps, dep_bookmarks, dep_configuration, dep_downloads, dep_pluginloader, ssconfig.dependencies(), lib_session_formats ],
install: true,
)